前言

在 Windows 下安装 Python 进行开发,经常会使用 pippip3 工具来安装各种第三方库,随着使用的深入,大概率会遇到 "error: Microsoft Visual C++ 14.0 or greater is required." 错误。

例如:我在安装 wordcloud 库时,就会报如下错误:

问题重现

下面就用最简单明了的方法来帮助大家完成依赖的安装,让你少走弯路。

如果最后教程帮助到你,也欢迎 点赞评论 转发,你的支持就是我坚持分享的动力,加油!

解决思路

仔细观察报错信息,其实程序已给出相关方案,只需下载并安装该程序即可:

下载相关软件:

  • 从提示的链接中获取软件:点这。
  • 从官方下载地址选择下载:点这。
  • 直接下载【Visual Studio 2022 生成工具】:点这。
Tips: 除了在官方下载该工具来安装缺失的 “Microsoft Visual C++ 14.0” 依赖,你还可以尝试在 IT天空 上下载 一键运行库

软件安装

第一步:双击运行下载好的 Visual Studio xxxx 生成工具

第二步:勾选下图提示依赖,然后点击安装。

第三步:重启电脑(可能需要)。

第四步:重新执行 Pip 安装即可。

完成。

最后修改:2021 年 11 月 30 日 04 : 07 PM